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Topological Editing    (modified from R Briggs UT-Dallas, by P. Bolstad)    9/17/2007 

 

For additional information, see  

--ESRI White Paper, Working with Geodatabase Topology, March 2003 (geodatabase-topology.pdf in ESRIdocuments 

directory in the class directory in 35 Skok) 

--ArcGIS>Help>Editing in ArcMap>Editing Toplogy 

--ESRI  ArcGIS 9: Editing in ArcMap, especially Chapter 4  Editing topology  (35 Skok directory) 

 

Topology:  relationships between spatial features, and rules about these relationships 

 --the concepts of connectivity (linked), congruency (same as/on top of), and contiguity (adjacent) 

 --relationships are between parts of features (nodes, vertices and edges) rather than the entire feature. 

Topology has been implemented in three ways: 

 --for coverages, as an integral part of the data,  

--old technology which is being replaced 

--implemented with CLEAN and BUILD commands 

  --CLEAN can move, create or remove geographic features 

  --BUILD modifies tables only 

  --requires ArcInfo (any versions since 1981) in order to be able to process coverages. 

 --for shapefiles (and feature classes in a gdb) as simple Map Topologies  (ArcGis 8.3 and later) 

--imposed during an edit session for  feature classes or shapefiles 

  --you simply define the shapefiles involved and set the tolerance 

  --all edges and vertices of features which are within the tolerance are considered shared 

  --there are no “rules,”  no need to validate topology, no error reports, etc. 

  --available with ArcView level of ArcGIS from Version 8.3 inward 

 --for feature classes, the more sophisticated Geodatabase (GDB) Topology (ArcGis 8.3 and later) 

--stored as a relationship class within a geodatabase feature dataset 

--separate from the data, which is not repositioned when topology is applied 

  --involves selecting rules, validating topology, etc.. 

  --requires ArcEditor or ArcInfo level of ArcGIS 

 

Simple Map Topology (if you only have the ArcView version of ArcGIS, as in the 1-year student edition) 

To turn on Map Topology,  

Click Editor button and select Start editing (if not already started)  

Click Editor button, click More editing tools and select Topology—topology toolbar opens 

Click the Map Topology button  , and  select the feature classe(s)/shapefile(s) that will participate. 

 Optionally, set a Cluster Tolerance  (e.g. 10 units) 

Any vertices or edges which are within the Cluster Tolerance of each other are considered “shared” and all will be moved if 

edited with the Topology Edit tool   

Always use this when editing polygons or line networks. 

Map topology exits only for the duration of the edit session. It is not stored (not even in the map document). Of course, any 

edits made based on the map topology will be saved if edits are saved.  Topology is useful: 

 --when you want to edit shared components of features (e.g. the common boundary between two polygons)  

 --when you only have ArcView 

 --when you want to edit shared components of shapefiles 

--when you want to edit shared components of two geodatabase feature classes which are in separate feature 

datasets or in two different existing geodatabase topologies 

 

Geodatabase Topology Concepts       

Available only with ArcEditor or ArcInfo levels of ArcGIS. 

Topology may be defined:  

 --between feature classes (e.g. state boundaries must coincide with county boundaries) 

 --within a feature class (e.g. county boundaries cannot overlap) 

 --between subtypes (e.g. residential road type cannot connect to interstate highway road type) 

Topologies have three components 

 --rules:  about permissible spatial relationships (see above for examples) 

--cluster tolerances: how close vertices must be to be considered coincident, and how far features can be moved 

Rule of thumb is that this should be at least one order of magnitude (1/10
th

) less than the accuracy of your data  (if 

data accuracy is 2 meters, topology tolerance should be  0.2 meters or 20 cms) 
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--ranks: which features move (lower rank features move to match higher rank e.g counties (2) move to state (1)) 

Topology rules exist for: 

 --polygons: 10 rules --1 not yet implemented ( for tesselations) 

 --lines: 12 rules 

 --points: 4 rules  

 Some rules apply to relationships between different files types e.g polygons relative to lines, etc.. 

Topologies are: 

--created in ArcCatalog  (by selecting appropriate rules) 

--validated in ArcCatalog or ArcMap using the Validate Topology command  

(which identifies potential errors)  

--viewed in ArcMap using the Error Inspector table  

--fixed  individually in ArcMap using  topology editing tools,  or marked as exceptions 

--fixed in batch (sometimes!)  in ArcMap or ArcToolbox using geoprocessing tools 

(See below for more information on fixing topological errors.) 

 

Topology status may be: 

 --Validated without errors. Validate Topology has been run and no errors found  

(or all have been fixed and Validate Topology run again to confirm this) 

--Validated with errors. Validate Toplogy has been run, errors found, and they have been: 

  --left unresolved 

  --marked as exceptions (and thus will not be tagged again if Validate Toplogy is rerun)  

--not Validated.  These are known as dirty areas. They cover the entire layer if Validate Topology has never been 

 run, or any area edited since the last time Validate Topology was run.  

 

The Effects of Running Topology.  When Validate  Topology is run the following occurs in succession:  

1. The first time Validate Topology is run, all feature vertices are aligned (moved!) to the integer grid of the 

spatial domain,. The amount of movement is a function of the precision of the spatial domain of the feature 

dataset. This is generally small, so the potential movement is also small, but should be recognized especially if 

data has been created by entering precise coordinates, as may be the case for survey data.. This assures that 

features are coincident and remain so.  

2. All vertices within the Cluster tolerance of each are combined; vertices in lower order feature classes  are 

moved to the location of vertices in higher order classes. A vertex is added if two lines intersect without a 

vertex being present.  

--it is possible for this  to result in the „disappearance” of lines or polygons 

 --a special topology rule (#26 in topo.ppt) is automatically applied to identify these cases. 

Overall. this process assures that  “shared geometries”  (coincident segments), such as the common boundary 

between two polygons, are recognized and that “shared editing”  will simultaneously adjust the boundary of 

both polygons..   

3. The topology rules which have been defined are verified,  and any violations are added to the error report.   

 

Fixing Topological Errors and Creating Topological structures 

There are various ways to fix topological errors, and/or create new topological structures, either individually or in 

batch. 

For  information, go to Help>Editing in ArcMap>Editing Topology>Topology Error fixes 

1. To fix errors individually, you can right click on the error in the Error Inspector table and an appropriate  tool 

is usually available.  For example; 

 Subtract removes overlaying feature segments  

 Simplify removes self overlapping segments 

 Extend  and Snap will fill gaps  

 Trim will remove dangles 

Merge will combine feature segments from one feature with another 

(some of these tools are also available directly on the Advanced Editing toolbar) 

2. you can run these same tools “in batch”  by using Shift or CTRL to select multiple errors simultaneously 

3. you can use the Topology Edit tool  on the Topology toolbar and standard editing to fix individual errors  

4. you can use one of the special topology tools on the Topology toolbar, which include: 
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Fix Topology Error tool  Don‟t be misled here. This  is not a general purpose tool. It is used for 

errors involving sliver polygons which need to be merged with primary polygons. 

Planarize Lines   tool, which is very powerful for “cleaning” lines. It will 

--remove overlapping line segments  (often needed) 

   --split lines where they intersect (which is often desired for GIS data) 

Construct features  tool, another powerful capability which will construct polygons or lines from the 

geometry of other features. 

Note:  All these tools require that you first select the features to be processed.  

For more info on these, go to Help>Editing in ArcMap>Editing Topology>Making new features with 

topology tools 

5. Use the Polygon Feature Class from Lines capability to create polygons from lines  

--This is in a strange place! You need to right click on a feature dataset and select New!  

  6. Use geoprocessing tools, such as those in: 

    ArcToolbox>Data Management Tools>Features 

   Check Geometry and Fix Geometry tools  useful for cleaning data 

   ArcToolbox>Data Management Tools>Generalize   

    Eliminate tool very useful for removing sliver polygons   

Be cautious when doing fixes in batch. There is the possibility you can  introduce false data, even if you fix the topological 

errors.  

See the examples below for the use of some of these. 

 

Managing topologies in ArcCatalog  

You can rename the topology without any negative effect 

If you copy  a topology, all associated feature data sets are also copied 

You cannot rename a feature class that is participating in a topology 

To delete a feature class that is participating in a topology, you must  first remove it from the topology 

  --to remove a  feature class, right click  topology name, select  Properties and click Feature Classes tab 

Other properties of an existing topology (e.g. rules, ranks) can also be modified via Properties 

 

Selected Topology Rules 

Topology Rules for Lines in Networks (examples) 

 Must not overlap  (one segment over another) 

 Must not intersect   (except at end points  e.g. lot lines should never cross themselves) 

 Must not have dangles (a good way to check for continuity; mark cul-de-sacs as exceptions) 

 Must not self overlap  (the same segment must not overlap itself) 

Other rules are available for relationship between two line segments 

Topology rules for Points related to  Lines 

 Must be covered by Line  (all points must lie on a line) 

 Must be covered by endpoint of (line must have point on end--point has the error) 

 Endpoint must be covered by (same as above but line has the error—don‟t use both!) 

See Building a Geodatabase in the class vault, under ESRI documents, for examples of all available topology rules 

 

Example Topology Application: Buildings and Parcels  

Create a geodatabase that contains buildings and roads shapefiles. You should work in directories on your local computer or 

flash drive (USB drive), by copying the data from the class directory, data\sample_data subdirectory. 

 

To create a Geodatabase: 

 Copy the buildings and parcel shapefiles from the class directory to a subdirectory on your flash drive 

On your flash drive, create a new personal geodatabase (start ArcCatalog, then File>New>Personal Geodatabase), 

named fixbuild. Note that will automatically be given the .mdb file extension. Note that you must specify a 

coordinate system, this exercise is UTM NAD83 zone 15, or you may import it from the buildings shapefile. 

Right click on the created fixbuild.mdb geodatabase, then select > New>Feature Dataset, name it something like 

property 

Right click on the created feature dataset (property), and Import>Feature Class (single) 

Select buildings.shp for the input, leave the output location for the property feature dataset, and name the output 

feature class something like builds_I_edited 
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Repeat the process to import the parcels, named something likes parcels. 

 

Create a topology in ArcCatalog   

In ArcCatalog, right-click the feature dataset (property) that will contain the topology, point to New and click Topology. 

Click Next to go past the introductory screen, and then Name the topology build_topology 

Set cluster tolerance at 0.5 meters (remember, implies that vertices can move up to 0.5 meters). Click Next  

Select layers to include in the topology: builds_I_edited, parcels.  Click Next 

 Set rank for builds_I_edited as 1, parcels as 2 (lower ranks move more.) Click Next 

Click Add rules and successively select, must not overlap, must not have gaps, must not overlap with parcel, and 

area boundary must be covered by boundary of parcel. Read about each rule as you enter, and click Next after 

each one.  

 Review summary. You should have 4 rules. Click Finish  

Click, Yes,  would like to validate it now. The topology is added to the feature dataset. 

      Right click on the topology name (build_topology), select Properties, click Errors tab, and then Generate Summary 

 There are 15 errors.  3--Must not have gaps 

  4--Must not overlap  with builds, parcel 

8—Area boundary must be covered by boundary…builds, parcel 

The number of errors will depend on the cluster tolerance. Generally, as you increase tolerance, errors decrease, 

but that is not always the case.  

 

View and Correct in ArcMap  

Open ArcMap and use Add data  , and navigate to the fixbuild.mdb and  add the property_topology just created  

When prompted, say Yes to add the feature classes also. 

Start editing  (Editor/Start Editing)  

Set the digitizing editing properties, left click the editor menu dropdown triangle , select options and set the 

snap tolerance to something appropriate (1 meter in this example), then OK, then select Snapping from 

the editor menu dropdown triangle, and set vertex and edge snapping on for the two data layers. 

Add the topology toolbar if necessary via Editor/More Editing tools/Topology 

Select property_Topology (or whatever you named it) in drop down window 

If topology has not been validated, click the Validate Topology button  

Click Error Inspector icon  to open error report 

To list all errors: in  Show  window, select <Errors from all rules>,  

place check in Errors and Exceptions boxes, & remove check from Visible Extent only box. 

Click Search Now button   

In the rows of the table, right click on a row and select Zoom to or Pan to to see  each error more clearly 

 --the  error changes from red to black on the map 

 --choose a “must not overlap” error and zoom in 

  --if you select feature on either side with selection tool, the segments overlap  

Click a column heading to sort by that column (e.g. Rule type) 

 --can use Shift and Control keys  to select multiple errors simultaneously for evaluation. 

 To fix errors individually, you can right click on the error in the table and there is a tool available in the menu 

  --for example, right click on a “must not overlap error” row in error table and zoom to the error 

  --right click again and select  Subtract—you will need to think carefully about which segment to subtract 

 For more information on fixes, go to Help>Editing in ArcMap>Editing Topology>Topology Error fixes 

  

Example Topology Application ---Census Tract data  

(Example uses census tract shapefile data, TR50_start, TR50LINEv9, etc., in the class vault data\sample_data directory ),  

 

Create and Validate in ArcCatalog  

In ArcCatalog, create a new geodatabase, feature dataset, an import the shapefile that begin with TR50_start into 

feature classes.   

Right-click the feature dataset that will contain the topology, point to New and click Topology. 

Click Next to go past the introductory screen, and then Name the topology tracts_topology 

Set cluster tolerance at 25 feet (remember, implies that vertices can move up to 25 feet). Click Next 

Select layers to include in the topology: tr50_start  

 Set rank for tr50_start as 1  (only relevant if have >1 layer in topo. Lower ranks move more.) Click Next 

  Click Add rules and successively select Must not overlap,  Must not have gaps. Click Next  

 Review summary. Be sure that you have 2 rules. Click Finish  
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Click, Yes,  would like to validate it now. The topology is added to the feature dataset. 

      Right click on the topology name (tracts_topology), select Properties, click Errors tab, and then Generate Summary 

 For the tr50_start file there are 4 Must not have gaps errors 

 

View and Correct in ArcMap  

Open ArcMap and use Add data   to add the topology.   

When prompted, say Yes to add the feature classes also. 

Start editing  (Editor/Start Editing)  

Add the topology toolbar if necessary via Editor/More Editing tools/Topology 

If topology has not been validated, click the Validate Topology button  

Click Error Inspector icon  to open error report 

To list all errors: in  Show  window, select <Errors from all rules>,  

place check in Errors and Exceptions boxes, & remove check from Visible Extent only box. 

Click Search Now button   

In the rows of the table, right click on a row and select Zoom to or Pan to to see  each error more clearly 

 --you may then need to use fixed zoom buttons to understand error better  

 --for example, last error  is generated by a “multi-part polygon.”  

Open Attribute table, select feature, and note it is one row (ObjectId=71).   

  To fix this, you can use the Explode icon  on the Advanced Editing toolbar  

   --this converts a multi-part polygon into separate polygons 

--it creates two new rows in attribute table, and removes original polygon 

   --delete the smaller (based on area) of the two new polygons 

  Revalidate the topology by clicking the Revalidate button  

  Click Seach Now  button again and you should only have 3 errors 

 

Zoom to third  error (now the  last if you have fixed and revalidated 4th error as above) 

 --it‟s a gap polygon, which needs to be removed 

 --go to Editor/Snapping and be sure that snapping is set for 

   tr50_start    Edge, in the upper window 

  and,  Topology Elements  Topology nodes in the lower window 

 --Under Editor/Options  set tolerance to 50 feet 

--Select Topology Edit tool  and double click on the lower left edge of the gap. Remove the gap by 

dragging the vertex in the lower left  so it snaps to the upper right edge of the gap. 

--Revalidate the topology by clicking the Revalidate button  

  Click Seach Now  button again and you should only have 2 errors. 

 


